Dear PHP Internals Team,

I hope this message finds you well. I am writing to request RFC karma for
my wiki account in order to propose a new RFC.

My proposal involves the introduction of two new methods, any_empty and
all_empty, for working with arrays. These methods are designed to provide
boolean outputs indicating whether any of the elements in an array are
empty, or if all elements are empty, respectively. I believe these methods
will be valuable additions to PHP’s array manipulation functionalities.

Below is a brief overview of the proposed methods:

any_empty(array $array): bool - This method will return true if any element
in the provided array is empty, and false otherwise.
all_empty(array $array): bool - This method will return true if all
elements in the provided array are empty, and false otherwise.
These methods aim to simplify common array checks and improve code
readability and efficiency.

I look forward to your approval and any guidance you can provide on moving
forward with this proposal.

Thank you for your time and consideration.

 image.png
<https://drive.google.com/file/d/1AdSZUstEqmgs_fGRiGde3sdf3q3XogaG/view?usp=drive_web>



Best regards,

Elminson
PHP Wiki Username: elminson

Reply via email to