Hello David,

  nice constructive helpfull work, thanks!

best regardws
marcus

Monday, August 15, 2005, 8:49:35 PM, you wrote:

> As a decreasingly "hardcore" php user, any and/or all items on Rasmus'
> wishlist would be welcome. However, to comment on two items....

> The strpos/in_array argument swap is one of my greatest joys in PHP. It
> keeps it lively. So I did a quick grep of the manual for "needle/haystack"
> type functions, and came up with the following. Perhaps there are other
> functions that use different argument names that I missed. There are
> really only 3 functions (array_key_exists, array_search and in_array) that
> use "needle, haystack" and are out of step with the others that use
> "haystack, needle".

> ----------------------------------------------
> array_key_exists ( mixed key, array search)
> array_search ( mixed needle, array haystack [, bool strict])
> iconv_strpos ( string haystack, string needle [, int offset [, string
> charset]])
> iconv_strrpos ( string haystack, string needle [, string charset])
> in_array ( mixed needle, array haystack [, bool strict])
> mb_strpos ( string haystack, string needle [, int offset [, string
> encoding]])
> mb_strrpos ( string haystack, string needle [, string encoding])
> mb_substr_count ( string haystack, string needle [, string encoding])
> stripos ( string haystack, string needle [, int offset])
> stristr ( string haystack, string needle)
> strpbrk ( string haystack, string char_list)
> strpos ( string haystack, string needle [, int offset])
> strrchr ( string haystack, string needle)
> strripos ( string haystack, string needle [, int offset])
> strrpos ( string haystack, string needle [, int offset])
> strstr ( string haystack, string needle)
> substr_count ( string haystack, string needle)
> ----------------------------------------------

> My other great joy in PHP is the function naming (especially the str*
> family). Although I can actually remember which are str_* and which are
> str* (while I can NEVER remember the argument order of strpos), it would
> be nice to make naming consistent. So why are aliases (str_pos, str_tok,
> htmlentities_decode, etc.) out of the question? Indeed, I have a colleague
> who still uses mysql_numrows, mysql_fieldname and friends (of course, he
> also still runs PHP3 :).




Best regards,
 Marcus

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to