[ 
https://issues.apache.org/jira/browse/AMBARI-23672?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

KuiLIU updated AMBARI-23672:
----------------------------
    Description: 
The following method is named as "extractXXX", but it just returns a LinkedList 
value.
Just naming it as "getXXX" should be more clear since "extractXXX" is prone to 
mean extracting something from a dataset.
{code:java}
 /**
   * @return : ordered collection of string of headers
   */
  public LinkedList<String> extractHeaders() {
    return headers;
  }
{code}


  was:
The following method is named as "extractXXX", but they just return a 
LinkedList value.
Just naming it as "getXXX" should be more clear since "extractXXX" is prone to 
mean extracting something from a dataset.
{code:java}
 /**
   * @return : ordered collection of string of headers
   */
  public LinkedList<String> extractHeaders() {
    return headers;
  }
{code}



> Inconsistent method names
> -------------------------
>
>                 Key: AMBARI-23672
>                 URL: https://issues.apache.org/jira/browse/AMBARI-23672
>             Project: Ambari
>          Issue Type: Improvement
>            Reporter: KuiLIU
>            Priority: Major
>
> The following method is named as "extractXXX", but it just returns a 
> LinkedList value.
> Just naming it as "getXXX" should be more clear since "extractXXX" is prone 
> to mean extracting something from a dataset.
> {code:java}
>  /**
>    * @return : ordered collection of string of headers
>    */
>   public LinkedList<String> extractHeaders() {
>     return headers;
>   }
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to