[ 
https://issues.apache.org/jira/browse/MATH-246?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12689147#action_12689147
 ] 

Luc Maisonobe commented on MATH-246:
------------------------------------

Apart fro some non-technical changes, here are the changes I would propose to 
add to this contribution:

Rename LinearEquation into LinearConstraint. It is only used for that purpose 
and could be confused at first sight with LinearObjectiveFunction.

Remove the LinearModel class, or at least change it to package private. This is 
an implementation detail. Users should see the simplest possible package and 
deal directly with objective function a set of constraints, a goal type and an 
optimizer.

Add a LinearOptimizer interface with an optimize method. This would be more 
consistent with the new optimization framework. The SimplexSolver would 
implement this interface. Setting solvers first and having a separate method to 
actually run them has already been asked for by users for root solvers (see 
MATH-218), it would be more consistent to follow the same pattern.

Remove GoalType from LinearObjectiveFunction. It seems better to pass it along 
with the objective function and the set of constraints when calling the 
optimize method.

Does this seems fair ?

> Simplex Method Implementation
> -----------------------------
>
>                 Key: MATH-246
>                 URL: https://issues.apache.org/jira/browse/MATH-246
>             Project: Commons Math
>          Issue Type: New Feature
>            Reporter: Benjamin McCann
>            Assignee: Luc Maisonobe
>             Fix For: 2.0
>
>         Attachments: newfiles.zip
>
>
> I've created an implementation of the Simplex algorithm for optimizing 
> systems of constrained linear equations that I'd like to contribute.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to