[
https://issues.apache.org/jira/browse/DRILL-3987?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14977502#comment-14977502
]
Jacques Nadeau commented on DRILL-3987:
---------------------------------------
some thoughts:
Drillbuf seems like it should be part of vectors (with a generic name).
An allocator interface should be included in vectors (and maybe a simple
allocator reference implementation)
I'm inclined to include ComplexWriter and FieldReader as part of the vectors as
a build interface.
I'm also inclined to include the RPC layer and a simple concept of batch
transfer
> Create a POC VV extraction
> --------------------------
>
> Key: DRILL-3987
> URL: https://issues.apache.org/jira/browse/DRILL-3987
> Project: Apache Drill
> Issue Type: Sub-task
> Reporter: Jacques Nadeau
> Assignee: Jacques Nadeau
>
> I'd like to start by looking at an extraction that pulls out the base
> concepts of:
> buffer allocation, value vectors and complexwriter/fieldreader.
> I need to figure out how to resolve some of the cross-dependency issues (such
> as the jdbc accessor connections).
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)