[ 
https://issues.apache.org/jira/browse/FLINK-655?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14280476#comment-14280476
 ] 

Henry Saputra commented on FLINK-655:
-------------------------------------

That's what I thought. I wanted to change the signature from List to Set for 
getBroadcastSet/withBroadcastset operations which I think should be more 
appropriate.

Would like to get thoughts/ opinions about it.


> Rename DataSet.withBroadcastSet(DataSet, String) method
> -------------------------------------------------------
>
>                 Key: FLINK-655
>                 URL: https://issues.apache.org/jira/browse/FLINK-655
>             Project: Flink
>          Issue Type: Improvement
>          Components: Java API
>            Reporter: Ufuk Celebi
>            Assignee: Henry Saputra
>              Labels: breaking-api, github-import, starter
>             Fix For: pre-apache
>
>
> To broadcast a data set you have to do the following:
> ```java
> lorem.map(new MyMapper()).withBroadcastSet(toBroadcast, "toBroadcastName")
> ```
> In the operator you call:
> ```java
> getRuntimeContext().getBroadcastVariable("toBroadcastName")
> ```
> I propose to have both method names consistent, e.g.
>   - `withBroadcastVariable(DataSet, String)`, or
>   - `getBroadcastSet(String)`.
> ---------------- Imported from GitHub ----------------
> Url: https://github.com/stratosphere/stratosphere/issues/655
> Created by: [uce|https://github.com/uce]
> Labels: enhancement, java api, user satisfaction, 
> Created at: Wed Apr 02 16:29:08 CEST 2014
> State: open



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to