[ 
https://issues.apache.org/jira/browse/FLINK-4422?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16140222#comment-16140222
 ] 

Stephan Ewen commented on FLINK-4422:
-------------------------------------

You can work on this, but I think this is fairly low priority. Looking at how 
many committers are currently very involved in other features (flip-6, 
dependency management, sql, network stack, ...) I assume that looking at a 
change like this (which nevertheless needs a thorough review) may take a while. 
If that is okay for you, feel free to approach this issue.

Concerning the use of a {{Clock}} abstraction - that can help with readability, 
but its main power is in allowing tests to set a different clock and control 
how time advances. That would need a lot more detail in planning this (for 
example {{sleep()}} would have to go through the clock as well).

> Convert all time interval measurements to System.nanoTime()
> -----------------------------------------------------------
>
>                 Key: FLINK-4422
>                 URL: https://issues.apache.org/jira/browse/FLINK-4422
>             Project: Flink
>          Issue Type: Sub-task
>          Components: Core
>            Reporter: Stephan Ewen
>            Assignee: Jin Mingjian
>            Priority: Minor
>
> In contrast to {{System.currentTimeMillis()}}, {{System.nanoTime()}} is 
> monotonous. To measure delays and time intervals, {{System.nanoTime()}} is 
> hence reliable, while {{System.currentTimeMillis()}} is not.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to