[ 
https://issues.apache.org/jira/browse/FLINK-7495?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Ted Yu updated FLINK-7495:
--------------------------
    Description: 
{code}
    recoveredStreamElements = context
      .getOperatorStateStore()
      .getListState(new ListStateDescriptor<>(STATE_NAME, 
inStreamElementSerializer));
{code}

Call to AbstractUdfStreamOperator#initializeState() should be added in the 
beginning

  was:
{code}
    recoveredStreamElements = context
      .getOperatorStateStore()
      .getListState(new ListStateDescriptor<>(STATE_NAME, 
inStreamElementSerializer));
{code}
Call to AbstractUdfStreamOperator#initializeState() should be added in the 
beginning


> AbstractUdfStreamOperator#initializeState() should be called in 
> AsyncWaitOperator#initializeState()
> ---------------------------------------------------------------------------------------------------
>
>                 Key: FLINK-7495
>                 URL: https://issues.apache.org/jira/browse/FLINK-7495
>             Project: Flink
>          Issue Type: Bug
>            Reporter: Ted Yu
>            Assignee: Fang Yong
>            Priority: Minor
>
> {code}
>     recoveredStreamElements = context
>       .getOperatorStateStore()
>       .getListState(new ListStateDescriptor<>(STATE_NAME, 
> inStreamElementSerializer));
> {code}
> Call to AbstractUdfStreamOperator#initializeState() should be added in the 
> beginning



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to