[
https://issues.apache.org/jira/browse/FLINK-3055?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15027790#comment-15027790
]
jun aoki commented on FLINK-3055:
---------------------------------
I'd like to pick one and replace the other with it to eliminate the duplicate.
The question is which on to pick?
getParallelSubtaskIndex() is used many places (20 according to my grep) and
getSubTaskIndex() is 3. However, getSubTaskIndex() seems a better name since at
ExecutionJobVertex (the caller class) point of view, "parallel" is already
implied.
Any input?
> ExecutionVertex has duplicate method getParallelSubtaskIndex and
> getSubTaskIndex
> --------------------------------------------------------------------------------
>
> Key: FLINK-3055
> URL: https://issues.apache.org/jira/browse/FLINK-3055
> Project: Flink
> Issue Type: Improvement
> Components: Distributed Runtime
> Affects Versions: 0.10.0
> Reporter: Ufuk Celebi
> Assignee: jun aoki
> Priority: Trivial
>
> In {{ExecutionVertex}}:
> {code}
> public int getSubTaskIndex() {
> return subTaskIndex;
> }
> public int getParallelSubtaskIndex() {
> return this.subTaskIndex;
> }
> {code}
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)