[
https://issues.apache.org/jira/browse/FLINK-16494?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]
Zili Chen reassigned FLINK-16494:
---------------------------------
Assignee: Canbin Zheng
> Use enum type instead of string type for
> KubernetesConfigOptions.CONTAINER_IMAGE_PULL_POLICY
> --------------------------------------------------------------------------------------------
>
> Key: FLINK-16494
> URL: https://issues.apache.org/jira/browse/FLINK-16494
> Project: Flink
> Issue Type: Improvement
> Components: Deployment / Kubernetes
> Reporter: Canbin Zheng
> Assignee: Canbin Zheng
> Priority: Minor
> Fix For: 1.11.0
>
>
> At the moment the value of
> KubernetesConfigOptions.{color:#172b4d}CONTAINER_IMAGE_PULL_POLICY
> {color}option could only be one of
> _{color:#172b4d}Always{color}_{color:#172b4d},
> {color}_{color:#172b4d}Never{color}{color:#172b4d}, and IfNotPresent{color}_,
> this ticket proposes to use enum type for the option instead of string type.
--
This message was sent by Atlassian Jira
(v8.3.4#803005)