[ 
https://issues.apache.org/jira/browse/FLINK-19409?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Liu updated FLINK-19409:
------------------------
    Description: 
The comment for getValue is as following currently:
{code:java}
*    @Override  
*    public Long getValue(MyAccumulator accumulator) {  
*        accumulator.list.add(id);  
*        ... ...  
*        accumulator.list.get()  
*         ... ...  
*        return accumulator.count;  
*    }  
{code}
 Users may be confused with the code "accumulator.list.add(id); ". It should be 
removed. 

 

  was:
The comment for getValue is as following currently:
{code:java}
// code placeholder
{code}
*    @Override 

*    public Long getValue(MyAccumulator accumulator) { 

*        accumulator.list.add(id); 

*        ... ... 

*        accumulator.list.get() 

*         ... ... 

*        return accumulator.count; 

*    }

 

Users may be confused with the code "accumulator.list.add(id); ". It should be 
removed. 

 


> The comment for getValue has wrong code in class ListView
> ---------------------------------------------------------
>
>                 Key: FLINK-19409
>                 URL: https://issues.apache.org/jira/browse/FLINK-19409
>             Project: Flink
>          Issue Type: Improvement
>          Components: Documentation
>            Reporter: Liu
>            Priority: Minor
>
> The comment for getValue is as following currently:
> {code:java}
> *    @Override  
> *    public Long getValue(MyAccumulator accumulator) {  
> *        accumulator.list.add(id);  
> *        ... ...  
> *        accumulator.list.get()  
> *         ... ...  
> *        return accumulator.count;  
> *    }  
> {code}
>  Users may be confused with the code "accumulator.list.add(id); ". It should 
> be removed. 
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Reply via email to