Zhuoxi2000 commented on issue #1013: URL: https://github.com/apache/flink-agents/issues/1013#issuecomment-5294986865
I'd like to take this one. My plan is to name the async worker threads in both runtimes so they’re easier to identify in thread dumps and profiler output. For Java, I’ll add a `ThreadFactory` and use names like `flink-agents-async-<n>`, keeping the current daemon behavior and pool sizing unchanged. For Python, I’ll set `thread_name_prefix="flink-agents-async"` on the `ThreadPoolExecutor`. Happy to use a different naming scheme if you have a preference. -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected]
