[ 
https://issues.apache.org/jira/browse/FLINK-6257?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15958140#comment-15958140
 ] 

sunjincheng commented on FLINK-6257:
------------------------------------

Hi,[~fhueske] That's fine. 
About {{Consistent naming of ProcessFunctions and methods}}, I want consistent 
them by the follow rule:
For class name:
{code}
(ProcTime/RowTime) + (Bounded/Unbounded) + [Partitioned/NonPartitioned] +  
[Range/Rows] + Over}}
{code}

Then we'll get the follow class names:

*ProcTimeBoundedRangeOver
*ProcTimeBoundedRowsOver
*ProcTimeUnboundedPartitionedOver
*ProcTimeUnboundedNonPartitionedOver
*RowTimeBoundedRangeOver
*RowTimeBoundedRowsOver
*RowTimeUnboundedOver(abstract)
*RowTimeUnboundedRangeOver
*RowTimeUnboundedRowsOver

For methods:
{code}
create + className + processFunction
{code}

What do you think?
Best,
SunJincheng

> Post-pass OVER windows
> ----------------------
>
>                 Key: FLINK-6257
>                 URL: https://issues.apache.org/jira/browse/FLINK-6257
>             Project: Flink
>          Issue Type: Sub-task
>          Components: Table API & SQL
>    Affects Versions: 1.3.0
>            Reporter: Fabian Hueske
>            Assignee: sunjincheng
>            Priority: Critical
>
> The OVER windows have been implemented by several contributors.
> We should do a post pass over the contributed code and improve a few things.
> * Functionality
> ** Currently every time attribute is allowed as ORDER BY attribute. We must 
> check that this is actually a time indicator ({{procTime()}}, {{rowTime()}}) 
> and that the order is ASCENDING.
> * Documentation
> ** Add documentation for OVER windows
> * Code style
> ** Consistent naming of {{ProcessFunctions}} and methods
> * Tests
> ** Move the OVER window tests out of SqlITCase into a dedicated class
> ** Move the OVER window tests out of WindowAggregateTest into a dedicated 
> class
> ** Add tests based on the test harness for all {{ProcessFunctions}} similar 
> to {{BoundedProcessingOverRangeProcessFunction}}. The tests should include 
> exact boundary checks for range windows and check for proper parallelization 
> with multiple keys.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Reply via email to