[ 
https://issues.apache.org/jira/browse/HBASE-3812?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13024854#comment-13024854
 ] 

jirapos...@reviews.apache.org commented on HBASE-3812:
------------------------------------------------------


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/660/
-----------------------------------------------------------

Review request for hbase and Gary Helmling.


Summary
-------

As described at hbase-3812:
* rename BaseRegionObserverCoprocessor -> BaseRegionObserver
* in BaseMasterObserver, rename ObserverContext parameter variable from "env" 
to "c" or "ctx"
* unnecessary public modifier for methods in RegionObserver interface


This addresses bug hbase-3812.
    https://issues.apache.org/jira/browse/hbase-3812


Diffs
-----

  src/main/java/org/apache/hadoop/hbase/coprocessor/BaseMasterObserver.java 
8df6aa4 
  src/main/java/org/apache/hadoop/hbase/coprocessor/BaseRegionObserver.java 
PRE-CREATION 
  
src/main/java/org/apache/hadoop/hbase/coprocessor/BaseRegionObserverCoprocessor.java
 a8c7cb2 
  src/main/java/org/apache/hadoop/hbase/coprocessor/RegionObserver.java 5c5d18d 
  
src/test/java/org/apache/hadoop/hbase/coprocessor/SampleRegionWALObserver.java 
c1fe58d 
  src/test/java/org/apache/hadoop/hbase/coprocessor/SimpleRegionObserver.java 
e201b3f 
  
src/test/java/org/apache/hadoop/hbase/coprocessor/TestCoprocessorInterface.java 
0a07e03 
  
src/test/java/org/apache/hadoop/hbase/coprocessor/TestRegionObserverStacking.java
 20a8d7d 
  src/test/java/org/apache/hadoop/hbase/coprocessor/TestWALCoprocessors.java 
27c38f9 
  src/test/java/org/apache/hadoop/hbase/coprocessor/TestWALObserver.java 
PRE-CREATION 

Diff: https://reviews.apache.org/r/660/diff


Testing
-------

Tests passed locally.


Thanks,

Mingjie



> Tidy up naming consistency and documentation in coprocessor framework
> ---------------------------------------------------------------------
>
>                 Key: HBASE-3812
>                 URL: https://issues.apache.org/jira/browse/HBASE-3812
>             Project: HBase
>          Issue Type: Improvement
>          Components: coprocessors
>            Reporter: Gary Helmling
>            Priority: Critical
>             Fix For: 0.92.0
>
>
> We have a few naming inconsistencies in the coprocessor API and some stale 
> javadocs that have been spotted by Lars George as he digs through it.  We 
> should clean these up before we have an official release and are forced to go 
> through a round of deprecation to make any changes.
> Current items on the list:
>  * rename BaseRegionObserverCoprocessor -> BaseRegionObserver
>  * in BaseMasterObserver, rename ObserverContext parameter variable from 
> "env" to "c" or "ctx"
>  * unnecessary public modifier for methods in RegionObserver interface
> As part of this, we should take a pass through the javadocs and verify they 
> are up to date with what is currently implemented.
> Please tack on other cosmetic changes or inconsistencies as you find them.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to