[ https://issues.apache.org/jira/browse/HBASE-8877?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Dave Latham updated HBASE-8877: ------------------------------- Attachment: HBASE-8877-refCounts.patch Alright, here's a patch with reentrant row locks and reference counts. This patch updates the row lock interface on HRegion to the following methods: - RowLock HRegion.getRowLock(final byte[] row, boolean waitForLock): acquire lock, optionally wait for lock - RowLock HRegion.getRowLock(final byte[] row): acquire lock, always waits for lock - RowLock.release(): releases the row lock The same thread can acquire multiple locks on the same row, but must release them all. doMiniBatchMutate now keeps a List of row locks (one for each row) and releases them all. While reviewing the clients I noticed that HRegion.increment and the duplicated code in HRegion.append both had possible paths to fail to release their row locks so I added a try/finally block to ensure they always release their locks. All the tests pass locally. I will run the microbenchmark too and post the results. > Reentrant row locks > ------------------- > > Key: HBASE-8877 > URL: https://issues.apache.org/jira/browse/HBASE-8877 > Project: HBase > Issue Type: Bug > Components: Coprocessors, regionserver > Reporter: Dave Latham > Assignee: Dave Latham > Fix For: 0.95.2 > > Attachments: hbase-8877-0.94-microbenchmark.txt, > HBASE-8877-0.94.patch, HBASE-8877-0.94-v2.patch, HBASE-8877.patch, > HBASE-8877-refCounts.patch, HBASE-8877-v2.patch, HBASE-8877-v3.patch, > hbase-8877-v4-microbenchmark.txt, HBASE-8877-v4.patch, HBASE-8877-v5.patch, > HBASE-8877-v6.patch, HBASE-8877-v7.patch > > > HBASE-8806 revealed performance problems with batch mutations failing to > reacquire the same row locks. It looks like HBASE-8806 will use a less > intrusive change for 0.94 to have batch mutations track their own row locks > and not attempt to reacquire them. Another approach will be to support > reentrant row locks directly. This allows simplifying a great deal of > calling code to no longer track and pass around lock ids. > One affect this change will have is changing the RegionObserver coprocessor's > methods preBatchMutate and postBatchMutate from taking a > {{MiniBatchOperationInProgress<Pair<Mutation, Integer>> miniBatchOp}} to > taking a {{MiniBatchOperationInProgress<Mutation> miniBatchOp}}. I don't > believe CPs should be relying on these lock ids, but that's a potential > incompatibility. -- This message is automatically generated by JIRA. If you think it was sent incorrectly, please contact your JIRA administrators For more information on JIRA, see: http://www.atlassian.com/software/jira