[ 
https://issues.apache.org/jira/browse/HBASE-9230?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

stack updated HBASE-9230:
-------------------------

    Attachment: 9230.txt

Patch looks bigger than it really is because has pb changes:

{code}
M 
hbase-client/src/main/java/org/apache/hadoop/hbase/client/MultiServerCallable.java
  Add check if cellblock and if NOT, then send request pure pb.
  It may look like duplicate code in the below.  It is not.  The calls to
  RequestConverter are different taking different params (overrides)
  isCellBlock -- does a test if we are to send cell blocks by looking at 
Configuration.

M hbase-client/src/main/java/org/apache/hadoop/hbase/ipc/IPCUtil.java
  If a CellScanner is not null and codec is, throw exception.

M 
hbase-client/src/main/java/org/apache/hadoop/hbase/ipc/PayloadCarryingRpcController.java
  Allow null value.

M hbase-client/src/main/java/org/apache/hadoop/hbase/ipc/RpcClient.java
  Allow for no codec being specified.

M 
hbase-client/src/main/java/org/apache/hadoop/hbase/protobuf/ResponseConverter.java
  The ScanResult protobuf changed slightly.  We do not have the ResultCellMeta 
anymore.
  Its content is moved into the pb Result.  Also, ScanResult may also carry
  its results inline as protobuf rather than always as cellblocks.

M hbase-common/src/main/java/org/apache/hadoop/hbase/CellScanner.java
  Fix javadoc.

M hbase-common/src/main/java/org/apache/hadoop/hbase/CellUtil.java
  Allow for null scanner.  Fix javadoc too.

M hbase-protocol/src/main/protobuf/Client.proto
  Removed ResultCellMeta.  Move its content into ScanResponse.
  Also allow carrying Results in the ScanResponse rather than as
  always cellblocks.

M hbase-protocol/src/main/protobuf/RPC.proto
  Remove default codec so it is possible to ask for NO codec.

M hbase-server/src/main/java/org/apache/hadoop/hbase/catalog/MetaEditor.java
  Remove unused import.

M hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/RpcCallContext.java
  isClientCellBlockSupport -- true if client wants response as cellblocks.

M hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/RpcServer.java
  Add support for isClientCellBlockSupport.  Its in RpcCallContext so can
  tell among the many connected clients which support cellblock returns.

M hbase-server/src/main/java/org/apache/hadoop/hbase/ipc/RpcServerInterface.java
  Removed imports.

M 
hbase-server/src/main/java/org/apache/hadoop/hbase/regionserver/HRegionServer.java
  Return results pb'd if client wants pb-only.

M 
hbase-server/src/test/java/org/apache/hadoop/hbase/client/TestFromClientSide.java
M 
hbase-server/src/test/java/org/apache/hadoop/hbase/catalog/TestMetaReaderEditorNoCluster.java
M 
hbase-server/src/test/java/org/apache/hadoop/hbase/master/MockRegionServer.java
M 
hbase-server/src/test/java/org/apache/hadoop/hbase/master/TestAssignmentManager.java
  Adjust because no more ResultCellMeta.

A 
hbase-server/src/test/java/org/apache/hadoop/hbase/client/TestFromClientSideNoCodec.java
  Small unit test that does basic ops w/o using a codec/cellblock.

M hbase-server/src/test/java/org/apache/hadoop/hbase/ipc/TestIPC.java
  Add test for  no codec.

M  src/main/docbkx/rpc.xml
  Add some doc.
                
> Fix the server so it can take a pure pb request param and return a pure pb 
> result
> ---------------------------------------------------------------------------------
>
>                 Key: HBASE-9230
>                 URL: https://issues.apache.org/jira/browse/HBASE-9230
>             Project: HBase
>          Issue Type: Bug
>            Reporter: stack
>            Assignee: stack
>            Priority: Critical
>             Fix For: 0.96.0
>
>         Attachments: 9230.txt
>
>
> Working on the asynchbase update w/ B this afternoon so it can run against 
> 0.95/0.96, I noticed that clients HAVE TO do cellblocks as the server is 
> currently.  That is an oversight.  Lets fix so can do all pb all the time too 
> (I thought this was there but it is not); it will make it easier dev'ing 
> simple clients.
> This issue shouldn't hold up release but we should get it in to help the 
> asynchbase convertion.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to