[ 
https://issues.apache.org/jira/browse/HBASE-8465?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13816930#comment-13816930
 ] 

Enis Soztutar commented on HBASE-8465:
--------------------------------------

I was reading the restore code for something else, and was very surprised by 
automatic taking of the snapshots. We also do not delete that snapshot even 
after the restore is successful. 

+1 on introducing an API where taking a snapshot before restore is configurable 
(through arg passing, not conf). Also in case the snapshot restore is success, 
we should delete the previous snapshot. The arg name for this 
(dropRollbackSnapshot) might be confusing since the user might think that it 
will drop the original snapshot, not the one for restore. 


> Auto-drop rollback snapshot for snapshot restore
> ------------------------------------------------
>
>                 Key: HBASE-8465
>                 URL: https://issues.apache.org/jira/browse/HBASE-8465
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Ted Yu
>            Assignee: Ted Yu
>             Fix For: 0.98.0, 0.96.1
>
>         Attachments: 8465-trunk-v1.txt, 8465-trunk-v2.txt
>
>
> Below is an excerpt from snapshot restore javadoc:
> {code}
>    * Restore the specified snapshot on the original table. (The table must be 
> disabled)
>    * Before restoring the table, a new snapshot with the current table state 
> is created.
>    * In case of failure, the table will be rolled back to the its original 
> state.
> {code}
> We can improve the handling of rollbackSnapshot in two ways:
> 1. give better name to the rollbackSnapshot (adding 
> {code}'-for-rollback-'{code}). Currently the name is of the form:
>     String rollbackSnapshot = snapshotName + "-" + 
> EnvironmentEdgeManager.currentTimeMillis();
> 2. drop rollbackSnapshot at the end of restoreSnapshot() if the restore is 
> successful. We can introduce new config param, named 
> 'hbase.snapshot.restore.drop.rollback', to keep compatibility with current 
> behavior.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Reply via email to