[ https://issues.apache.org/jira/browse/HBASE-10137?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13850188#comment-13850188 ]
rajeshbabu commented on HBASE-10137: ------------------------------------ NP [~stack] As of now I will keep GeneralBulkAssigner as it is. Later if we find better name we can change it. > GeneralBulkAssigner with retain assignment plan can be used in > EnableTableHandler to bulk assign the regions > ------------------------------------------------------------------------------------------------------------ > > Key: HBASE-10137 > URL: https://issues.apache.org/jira/browse/HBASE-10137 > Project: HBase > Issue Type: Bug > Components: Region Assignment > Affects Versions: 0.96.0, 0.94.14 > Reporter: rajeshbabu > Assignee: rajeshbabu > Fix For: 0.98.0, 0.96.2, 0.99.0 > > Attachments: HBASE-10137.patch, HBASE-10137_v2.patch > > > Current in BulkEnabler we are assigning one region at a time, instead we can > use GeneralBulkAssigner to bulk assign multiple regions at a time. > {code} > for (HRegionInfo region : regions) { > if (assignmentManager.getRegionStates() > .isRegionInTransition(region)) { > continue; > } > final HRegionInfo hri = region; > pool.execute(Trace.wrap("BulkEnabler.populatePool",new Runnable() { > public void run() { > assignmentManager.assign(hri, true); > } > })); > } > {code} -- This message was sent by Atlassian JIRA (v6.1.4#6159)