[ 
https://issues.apache.org/jira/browse/HBASE-10566?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13910145#comment-13910145
 ] 

Nicolas Liochon commented on HBASE-10566:
-----------------------------------------

bq. I suppose it is ok. Maybe rename the class so it is not confused with 
Callable.
Actually, we never use the fact that it's a java Callable. But changing the 
name can impact a lot of code. I will try (intelliJ will do the change for me, 
but it can make the patch much bigger, I don"t know).

bq. Is TimeLimitedRpcController left as an exercise to the reader
I forgot it (usual stuff: not added to git, so not included in git diff). But 
the patch globally compiles but does not set the timeout all the time.

bq. Doesn't "callTimeout" make more sense for this parameter name?
Often timeout indicates a duration, while here I used something like a cutoff 
time. That's what I wanted to express. There is an implication however: the 
client and the server time must be in sync. Even if it's a common requirement, 
I'm not sure I'm not going to change my mind.

Thanks a lot for the feedback, I'm going to try to write the full patch.




> cleanup rpcTimeout in the client
> --------------------------------
>
>                 Key: HBASE-10566
>                 URL: https://issues.apache.org/jira/browse/HBASE-10566
>             Project: HBase
>          Issue Type: Bug
>          Components: Client
>    Affects Versions: 0.99.0
>            Reporter: Nicolas Liochon
>            Assignee: Nicolas Liochon
>             Fix For: 0.99.0
>
>         Attachments: 10566.sample.patch
>
>
> There are two issues:
> 1) A confusion between the socket timeout and the call timeout
> Socket timeouts should be minimal: a default like 20 seconds, that could be 
> lowered to single digits timeouts for some apps: if we can not write to the 
> socket in 10 second, we have an issue. This is different from the total 
> duration (send query + do query + receive query), that can be longer, as it 
> can include remotes calls on the server and so on. Today, we have a single 
> value, it does not allow us to have low socket read timeouts.
> 2) The timeout can be different between the calls. Typically, if the total 
> time, retries included is 60 seconds but failed after 2 seconds, then the 
> remaining is 58s. HBase does this today, but by hacking with a thread local 
> storage variable. It's a hack (it should have been a parameter of the 
> methods, the TLS allowed to bypass all the layers. May be protobuf makes this 
> complicated, to be confirmed), but as well it does not really work, because 
> we can have multithreading issues (we use the updated rpc timeout of someone 
> else, or we create a new BlockingRpcChannelImplementation with a random 
> default timeout).
> Ideally, we could send the call timeout to the server as well: it will be 
> able to dismiss alone the calls that it received but git stick in the request 
> queue or in the internal retries (on hdfs for example).
> This will make the system more reactive to failure.
> I think we can solve this now, especially after 10525. The main issue is to 
> something that fits well with protobuf...
> Then it should be easy to have a pool of thread for writers and readers, w/o 
> a single thread per region server as today. 



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Reply via email to