[ 
https://issues.apache.org/jira/browse/HBASE-10616?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13931159#comment-13931159
 ] 

Enis Soztutar commented on HBASE-10616:
---------------------------------------

HBASE-10572 is resolved. Let's get this in as well. 

LoadTestTool args have convention for using underscore, instead of camel case: 
{code}
+  public static final String OPT_MULTIGET = "multigetBatchSize";
{code}
Need Javadoc on the new IT test class. 
>From my reading of the code, the batch size will not be filled for almost all 
>the time, because we will be skipping keys, and keysForThisReader will not be 
>filled at all. 
{code}
+          if (k % numThreads != readerId ||
+              writer != null && writer.failedToWriteKey(k)) {
+            // Skip keys that this thread should not read, as well as the keys
+            // that we know the writer failed to write.
+            continue;
+          }
{code}
There is some code duplication. Can we simplify some paths, where a Get[]  with 
length 1 is a simple get, and multi get if length > 1. 



> Integration test for multi-get calls
> ------------------------------------
>
>                 Key: HBASE-10616
>                 URL: https://issues.apache.org/jira/browse/HBASE-10616
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Devaraj Das
>            Assignee: Devaraj Das
>         Attachments: 10616-1.txt, 10616-2.2.txt
>
>
> HBASE-10572 adds a test that does 'get' from client. We should add a similar 
> test for batch gets.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to