[ 
https://issues.apache.org/jira/browse/HBASE-10993?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13973792#comment-13973792
 ] 

stack commented on HBASE-10993:
-------------------------------

bq. Currently getPriority() means more "get request type" and is used to select 
the queue.

That is a good way of putting it.  Should this method name be changed to 
reflect what its actually doing then?  getPriorityQueue?  Or should getDeadline 
be called getSubPriority or getMinorPriority and getMajorPriority.

Maybe you don't want to change getPriority because this queue selection is 
kinda hacky and could go away?  If it did, how then would these two different 
priorities interact?

> Deprioritize long-running scanners
> ----------------------------------
>
>                 Key: HBASE-10993
>                 URL: https://issues.apache.org/jira/browse/HBASE-10993
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Matteo Bertozzi
>            Assignee: Matteo Bertozzi
>            Priority: Minor
>             Fix For: 1.0.0
>
>         Attachments: HBASE-10993-v0.patch, HBASE-10993-v1.patch
>
>
> Currently we have a single call queue that serves all the "normal user"  
> requests, and the requests are executed in FIFO.
> When running map-reduce jobs and user-queries on the same machine, we want to 
> prioritize the user-queries.
> Without changing too much code, and not having the user giving hints, we can 
> add a “vtime” field to the scanner, to keep track from how long is running. 
> And we can replace the callQueue with a priorityQueue. In this way we can 
> deprioritize long-running scans, the longer a scan request lives the less 
> priority it gets.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to