[ 
https://issues.apache.org/jira/browse/HBASE-4199?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13088307#comment-13088307
 ] 

Ted Yu commented on HBASE-4199:
-------------------------------

Patch version 4 is in a commit-table state. 

Minor comments:
In BlockCache:
{code}
+  public List<BlockCacheColumnFamilySummary> 
getBlockCacheColumnFamilySummary(Configuration conf) throws IOException {
{code}
I think getBlockCacheColumnFamilySummaries might be a better name.

For HRegionInterface:
{code}
+   * Performs a BlockCache summary and returns a List of 
BlockCacheColumnFamily objects.
{code}
BlockCacheColumnFamilySummary objects are returned. Again, the method name 
should pluralize Summaries.

Good work, Doug.

> blockCache summary - backend
> ----------------------------
>
>                 Key: HBASE-4199
>                 URL: https://issues.apache.org/jira/browse/HBASE-4199
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Doug Meil
>            Assignee: Doug Meil
>            Priority: Minor
>         Attachments: java_HBASE_4199.patch, java_HBASE_4199_v2.patch, 
> java_HBASE_4199_v3.patch, java_HBASE_4199_v4.patch
>
>
> This is the backend work for the blockCache summary.  Change to BlockCache 
> interface, Summarization in LruBlockCache, BlockCacheSummaryEntry, addition 
> to HRegionInterface, and HRegionServer.
> This will NOT include any of the web UI or anything else like that.  That is 
> for another sub-task.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to