[ 
https://issues.apache.org/jira/browse/HBASE-11826?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14110793#comment-14110793
 ] 

stack commented on HBASE-11826:
-------------------------------

IMO, need to keep the old stuff for 1.0. This stuff has been around a long time 
so probably a few tools out there that rely on it.  We want folks to be able to 
go from 0.94 to 1.0 w/o too much hassle.

> Split each tableOrRegionName admin methods into two targetted methods
> ---------------------------------------------------------------------
>
>                 Key: HBASE-11826
>                 URL: https://issues.apache.org/jira/browse/HBASE-11826
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Carter
>            Assignee: Carter
>
> Purpose of this is two implement [~enis]'s suggestion to strongly type the 
> methods that take "tableOrRegionName" as an argument.
> For instance:
> {code}
> void compact(final String tableNameOrRegionName)
> void compact(final byte[] tableNameOrRegionName)
> {code}
> becomes
> {code}
> @Deprecated
> void compact(final String tableNameOrRegionName)
> @Deprecated
> void compact(final byte[] tableNameOrRegionName)
> void compact(TableName table)
> void compactRegion(final byte[] regionName)
> {code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Reply via email to