[ 
https://issues.apache.org/jira/browse/HBASE-12096?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14149691#comment-14149691
 ] 

Ted Yu commented on HBASE-12096:
--------------------------------

{code}
       List<String> tasks = ZKUtil.listChildrenNoWatch(watcher, 
watcher.splitLogZNode);
{code}
Tried to trace what type of List is returned above.
Ending up in org.apache.zookeeper.proto.GetChildrenResponse :
{code}
  public GetChildrenResponse(
        java.util.List<String> children) {
    this.children=children;
  }
{code}
Would go into zookeeper code next.

> In ZKSplitLog Coordination and AggregateImplementation replace enhaced for 
> statements with basic for statement to avoid unnecessary object allocation
> -----------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-12096
>                 URL: https://issues.apache.org/jira/browse/HBASE-12096
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Ashish Singhi
>            Assignee: Ashish Singhi
>            Priority: Minor
>             Fix For: 2.0.0
>
>         Attachments: HBASE-12096.patch
>
>
> In ZKSplitLog Coordination classes and AggregateImplementation replace 
> enhanced for statements with basic for statement to avoid unnecessary object 
> allocation



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to