[ 
https://issues.apache.org/jira/browse/HBASE-13707?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14549211#comment-14549211
 ] 

Jean-Marc Spaggiari commented on HBASE-13707:
---------------------------------------------

Exactly. Very good for very wide tables with only few rows. You can still 
increase the maximum number of counters but it become crazy quickly.

[code]
            context.getCounter("QL_VERSIONS", currentRowKey + separator +
              thisRowQualifierName).increment(1);
[code]

It creates one counter per row using the rowkey as the name to give you how 
many cells and versions there is per row. It's still useful in some cases, but 
generally speaking it creates to many counters...

I think we should "simply" add an option to not count per row, but only per 
table, so just add a parameter and an if before this line.

> CellCounter uses to many counters
> ---------------------------------
>
>                 Key: HBASE-13707
>                 URL: https://issues.apache.org/jira/browse/HBASE-13707
>             Project: HBase
>          Issue Type: Bug
>          Components: mapreduce
>    Affects Versions: 1.0.1
>            Reporter: Jean-Marc Spaggiari
>            Priority: Minor
>              Labels: beginner, newbie
>
> CellCounters creates a counter per row... So it quickly becomes to many.
> We should provide an option to drop the statistic per rows and count only 
> cells overall for the table.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to