[ 
https://issues.apache.org/jira/browse/HBASE-14442?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Nathan updated HBASE-14442:
---------------------------
    Description: 
I created a Scan whose startRow and stopRow are the same with a region's 
startRow, then I found no map was built. 
The following is the source code of this condtion:
(startRow.length == 0 || keys.getSecond()[i].length == 0 ||
                    Bytes.compareTo(startRow, keys.getSecond()[i]) < 0) &&
                    (stopRow.length == 0 || Bytes.compareTo(stopRow,
                            keys.getFirst()[i]) > 0)

I think  a "=" should be added.

  was:
I created a Scan whose startRow and stopRow are the same with a region's 
startRow, then I found no map was built. 
The following is the source code of this condtion:
(startRow.length == 0 || keys.getSecond()[i].length == 0 ||
                    Bytes.compareTo(startRow, keys.getSecond()[i]) < 0) &&
                    (stopRow.length == 0 || Bytes.compareTo(stopRow,
                            keys.getFirst()[i]) > 0)

I think  a "=" to the "<" should be added.


> MultiTableInputFormatBase.getSplits dosenot build split for startRow of region
> ------------------------------------------------------------------------------
>
>                 Key: HBASE-14442
>                 URL: https://issues.apache.org/jira/browse/HBASE-14442
>             Project: HBase
>          Issue Type: Bug
>          Components: mapreduce
>    Affects Versions: 1.1.2
>            Reporter: Nathan
>            Assignee: Nathan
>   Original Estimate: 0.5h
>  Remaining Estimate: 0.5h
>
> I created a Scan whose startRow and stopRow are the same with a region's 
> startRow, then I found no map was built. 
> The following is the source code of this condtion:
> (startRow.length == 0 || keys.getSecond()[i].length == 0 ||
>                     Bytes.compareTo(startRow, keys.getSecond()[i]) < 0) &&
>                     (stopRow.length == 0 || Bytes.compareTo(stopRow,
>                             keys.getFirst()[i]) > 0)
> I think  a "=" should be added.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to