[ 
https://issues.apache.org/jira/browse/HBASE-14549?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Lars Hofhansl updated HBASE-14549:
----------------------------------
    Attachment: 14549-0.98.txt

Patch for 0.98.

Simply does away with checkReseek and the requirement to call it in scanner 
methods, instead inlines the logic in updateReaders.
There's no performance benefit from this. It simply places the logic where it 
belong, improving readability and possibly making it easier to change the logic 
(for example HBASE-13082) in the future as it is all in one place.


> Simplify scanner stack reset logic
> ----------------------------------
>
>                 Key: HBASE-14549
>                 URL: https://issues.apache.org/jira/browse/HBASE-14549
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Lars Hofhansl
>            Assignee: Lars Hofhansl
>         Attachments: 14549-0.98.txt
>
>
> Looking at the code, I find that the logic is unnecessarily complex.
> We indicate in updateReaders that the scanner stack needs to be reset. Than 
> almost all store scanner (and derived classes) methods need to check and 
> actually reset the scanner stack.
> Compaction are rare, we should reset the scanner stack in update readers, and 
> hence avoid needing to check in all methods.
> Patch forthcoming.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to