[ 
https://issues.apache.org/jira/browse/HBASE-15061?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15085399#comment-15085399
 ] 

Anoop Sam John commented on HBASE-15061:
----------------------------------------

In the new builder we have fields for cacheEnabled, pread etc with some default 
values. All fine.
We call withXXX method in the create places iff the value is not the default 
one.
What I was asking is whether we can call them even if the value is default one? 
  Or just add code level comments there that value for say cacheEnabled = true. 
 Just  readability aspect. Very minor suggestion :-)

> Refactor StoreFileScanner creation to builder pattern
> -----------------------------------------------------
>
>                 Key: HBASE-15061
>                 URL: https://issues.apache.org/jira/browse/HBASE-15061
>             Project: HBase
>          Issue Type: Improvement
>    Affects Versions: 2.0.0
>            Reporter: Jonathan Hsieh
>            Assignee: Jonathan Hsieh
>             Fix For: 2.0.0
>
>         Attachments: hbase-15061.patch, hbase-15061.v2.patch
>
>
> There are several falvors of  calls that creates a list of StoreFileScanners, 
> and new feature have been added to this recently.  This patch converts the 
> somewhat difficult to read (need to go to javadoc) call:
> {code}
> // which args are the most relevant to this?
> -      List<StoreFileScanner> sfScanners = 
> StoreFileScanner.getScannersForStoreFiles(sfs,
> -        cacheMobBlocks, true, false, false, readPt);
> {code}
> into one that is more literate:
> {code}
> // ah, very clearly we are using defaults except for the caching settings
> +      List<StoreFileScanner> sfScanners = new 
> StoreFileScanner.ListBuilder(sfs, readPt)
> +          .withCacheBlocks(cacheMobBlocks).build();
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to