[ 
https://issues.apache.org/jira/browse/HBASE-15334?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15184102#comment-15184102
 ] 

Ted Yu commented on HBASE-15334:
--------------------------------

{code}
+    val unioned = keySeq ++ valueSeq
{code}
Naming unioned as unionedRow would make the code more readable.

For SchemaConverters.scala, please add some scaladoc explaining what conversion 
utils are provided.
{code}
+      case STRING => SchemaType(StringType, nullable = false)
{code}
Why is STRING not nullable ?



> Add avro support for spark hbase connector
> ------------------------------------------
>
>                 Key: HBASE-15334
>                 URL: https://issues.apache.org/jira/browse/HBASE-15334
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Zhan Zhang
>            Assignee: Zhan Zhang
>         Attachments: HBASE-15334-1.patch
>
>
> Avro is a popular format for hbase storage. User may want the support 
> natively in the connector.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to