[ 
https://issues.apache.org/jira/browse/HBASE-15480?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15227139#comment-15227139
 ] 

Ted Yu commented on HBASE-15480:
--------------------------------

{code}
   * Check if the specified keys are contained in the bloom filter.
...
+  public BitSet contains(byte[][] key, int[] keyOffset, int[] keyLength, 
ByteBuff bloom) {
{code}
Since multiple keys are checked in the method, shouldn't the parameter names be 
in plural ?

BTW I don't find the caller for the new method.
Did I miss something ?

> Bloom Filter check needs to be more efficient for array
> -------------------------------------------------------
>
>                 Key: HBASE-15480
>                 URL: https://issues.apache.org/jira/browse/HBASE-15480
>             Project: HBase
>          Issue Type: Improvement
>          Components: Performance
>    Affects Versions: 1.0.3
>            Reporter: Walter Koetke
>            Assignee: Walter Koetke
>             Fix For: 1.0.4
>
>         Attachments: BloomFilterCheckOneByOne.tiff, 
> HBASE-15480-branch-1.0.patch, HBASE-15480.patch
>
>
> It is currently inefficient to do lots of bloom filter checks. Each check has 
> overhead like going to the block cache to retrieve the block and recording 
> metrics. It would be good to have one bloom filter check api that does a 
> bunch of checks without so much block retrieval and metrics updates.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to