[ 
https://issues.apache.org/jira/browse/HBASE-16197?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Ted Yu updated HBASE-16197:
---------------------------
    Attachment: 16197-suggest.patch

Here is suggested patch based on v9:

* used iterator in getBackupHistory(String backupRoot)

* For getBackupHistoryForTableSet(Set<TableName> set, String backupRoot), 
removed the loop assigning null for table names in tableHistoryMap

TestBackupMultipleDeletes passes.

See if the code is easier to read.

> Enchance backup delete command
> ------------------------------
>
>                 Key: HBASE-16197
>                 URL: https://issues.apache.org/jira/browse/HBASE-16197
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>            Reporter: Vladimir Rodionov
>            Assignee: Vladimir Rodionov
>             Fix For: 2.0.0
>
>         Attachments: 16197-suggest.patch, HBASE-16197-v1.patch, 
> HBASE-16197-v2.patch, HBASE-16197-v4.patch, HBASE-16197-v5.patch, 
> HBASE-16197-v6.patch, HBASE-16197-v7.patch, HBASE-16197-v8.patch, 
> HBASE-16197-v9.patch
>
>
> Currently, backup delete command deletes only physical files/directories in 
> backup destination. It does not update backup system table (incremental 
> backup table set) and it does not delete related backup images (previous 
> ones), thus creating a hole in dependency chain. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to