[ 
https://issues.apache.org/jira/browse/HBASE-16257?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15485653#comment-15485653
 ] 

Jerry He commented on HBASE-16257:
----------------------------------

bq. Can we either use all upper case or all lower case for the names of these
bq. Let's add a comment here talking about the layout of rootdir and the 
permissions of its subdirs.

Will do.

bq. This is now defined in two places

Hmm where is the other place?

bq. I was mentioning above that, for upgrades, we have to "open-up" the 
permissions for the root directory
Is the following ok?

{noformat}
+    // Handle the last few special files and set the final rootdir permissions
+    // rootdir needs 'x' for all for bulk load staging dir
+    if (isSecurityEnabled) {
+      fs.setPermission(new Path(rootdir, HConstants.VERSION_FILE_NAME), 
secureRootFilePerms);
+      fs.setPermission(new Path(rootdir, HConstants.CLUSTER_ID_FILE_NAME), 
secureRootFilePerms);
+    }
+    fs.setPermission(this.rootdir, this.rootPerms);
{noformat}

> Move staging dir to be under hbase root dir
> -------------------------------------------
>
>                 Key: HBASE-16257
>                 URL: https://issues.apache.org/jira/browse/HBASE-16257
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Jerry He
>            Assignee: Jerry He
>            Priority: Blocker
>             Fix For: 2.0.0
>
>         Attachments: HBASE-16257-v1.patch, HBASE-16257-v2.patch, 
> HBASE-16257-v3.patch
>
>
> The hbase.bulkload.staging.dir defaults to hbase.fs.tmp.dir which then 
> defaults to
> {code}
> public static final String DEFAULT_TEMPORARY_HDFS_DIRECTORY = "/user/"
>       + System.getProperty("user.name") + "/hbase-staging";
> {code}
> This default would have problem on local file system standalone case.
> We can move the staging dir to be under hbase.rootdir.  We are bringing 
> secure bulkload to the core. It makes sense to bring it under core control as 
> well, instead of an optional property.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to