[ 
https://issues.apache.org/jira/browse/HBASE-5016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13168898#comment-13168898
 ] 

Doug Meil commented on HBASE-5016:
----------------------------------

The patch to that class isn't what I'm worried about, it's a 1-liner.  It's the 
tests and any config change that is potentially depending on the invalid 
constant. 
                
> LoadBalancerFactory - "maser" in package name of dynamically loaded balancer 
> class?
> -----------------------------------------------------------------------------------
>
>                 Key: HBASE-5016
>                 URL: https://issues.apache.org/jira/browse/HBASE-5016
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Doug Meil
>
> Shouldn't this... "hbase.maser.loadBalancer.class" be something like 
> "hbase.master.loadBalancer.class"?  What's with "maser"?
> {code}
> /**
>  * The class that creates a load balancer from a conf.
>  */
> public class LoadBalancerFactory {
>   /**
>    * Create a loadblanacer from the given conf.
>    * @param conf
>    * @return A {@link LoadBalancer}
>    */
>   public static LoadBalancer getLoadBalancer(Configuration conf) {
>     // Create the balancer
>     Class<? extends LoadBalancer> balancerKlass = 
> conf.getClass("hbase.maser.loadBalancer.class",DefaultLoadBalancer.class, 
> LoadBalancer.class);
>     return ReflectionUtils.newInstance(balancerKlass, conf);
>   }
> }
> {code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to