[ 
https://issues.apache.org/jira/browse/HBASE-17249?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15724549#comment-15724549
 ] 

Anoop Sam John commented on HBASE-17249:
----------------------------------------

{code}
@Override public Scan setColumnFamilyTimeRange(byte[] cf, TimeRange tr) {
375         return (Scan) super.setColumnFamilyTimeRange(cf, tr);
376       }
{code}
Pls fix the formatting.  I can see in another place also.  Normally we will put 
@Override above the public...  method name line
Just noticing that we dont have setTimeRange in Query.   But not related to 
this patch.   if ok, can fix that also here.   Just like 
setColumnFamilyTimeRange.   But I leave it to u.

> Get/Scan's setTimeRange/setColumnFamilyTimeRange can take the TimeRange 
> reference as the parameter instead of creating a new setColumnFamilyTimeRange 
> instance
> --------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-17249
>                 URL: https://issues.apache.org/jira/browse/HBASE-17249
>             Project: HBase
>          Issue Type: Improvement
>    Affects Versions: 2.0.0
>            Reporter: huaxiang sun
>            Assignee: huaxiang sun
>            Priority: Minor
>         Attachments: HBASE-17249-master-001.patch, 
> HBASE-17249-master-002.patch
>
>
> Going through the code, found For Get/Scan's 
> setTimeRange/setColumnFamilyTimeRange, it can use  TimeRange as reference 
> instead of creating a new one.
> Reference:
> https://github.com/apache/hbase/blob/master/hbase-client/src/main/java/org/apache/hadoop/hbase/shaded/protobuf/ProtobufUtil.java#L500
> https://github.com/apache/hbase/blob/master/hbase-client/src/main/java/org/apache/hadoop/hbase/shaded/protobuf/ProtobufUtil.java#L506
> We can implement this in a similar way as filter:
> https://github.com/apache/hbase/blob/master/hbase-client/src/main/java/org/apache/hadoop/hbase/shaded/protobuf/ProtobufUtil.java#L510
> I checked it is same with branch-1.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to