[ 
https://issues.apache.org/jira/browse/HBASE-18509?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Appy updated HBASE-18509:
-------------------------
    Description: 
Track all types of cleanups here:
- Rename classes to more consistent naming: SystemClock, SystemMonotonicClock, 
HybridLogicalClock
- Move implementations out from Clock interface. It's a simple interface of 6 
fns but very overloaded right now with everything put inside it.
- Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
can just have getClocks() function.
{noformat}
class Clocks {
  // all 3 types of clocks.
  // Fns:
  - update(ClockType, timestamp)
  - updateAll(List\<NodeTime>)
  - int64 now(ClockType)
  - List\<NodeTime> nowAll()
  }
{noformat}


  was:
Track all types of cleanups here:
- Rename classes to more consistent naming: SystemClock, SystemMonotonicClock, 
HLClock
- Move implementations out from Clock interface. It's a simple interface of 6 
fns but very overloaded right now with everything put inside it.
- Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
can just have getClocks() function.
{noformat}
class Clocks {
  // all 3 types of clocks.
  // Fns:
  - update(ClockType, timestamp)
  - updateAll(List\<NodeTime>)
  - int64 now(ClockType)
  - List\<NodeTime> nowAll()
  }
{noformat}



> [HLC] Finishing cleanups
> ------------------------
>
>                 Key: HBASE-18509
>                 URL: https://issues.apache.org/jira/browse/HBASE-18509
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Appy
>            Assignee: Amit Patel
>         Attachments: HBASE-18509.HBASE-14070.HLC.001.patch
>
>
> Track all types of cleanups here:
> - Rename classes to more consistent naming: SystemClock, 
> SystemMonotonicClock, HybridLogicalClock
> - Move implementations out from Clock interface. It's a simple interface of 6 
> fns but very overloaded right now with everything put inside it.
> - Maybe encapsulate all clocks in RS/Master into a new class. Then RSServices 
> can just have getClocks() function.
> {noformat}
> class Clocks {
>   // all 3 types of clocks.
>   // Fns:
>   - update(ClockType, timestamp)
>   - updateAll(List\<NodeTime>)
>   - int64 now(ClockType)
>   - List\<NodeTime> nowAll()
>   }
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to