[ 
https://issues.apache.org/jira/browse/HBASE-16290?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16183589#comment-16183589
 ] 

Chia-Ping Tsai commented on HBASE-16290:
----------------------------------------

{code}
+        if(null != rpcCall.getMethod()) {
+          method = rpcCall.getMethod().getName();
+        } else {
+          method = "";
+        }
{code}
What about naming it "Unknown"? The {{""}} is ambiguous.

{code}
+  @Override
+  public CallQueueInfo getCallQueueInfo() {
+    String queueName = "Fifo Queue";
+    CallQueueInfo callQueueInfo = new CallQueueInfo();
+
+    HashMap<String, Long> callQueueMethodTotalCount = new HashMap<>();
+    HashMap<String, Long> callQueueMethodTotalSize = new HashMap<>();
+
+    callQueueMethodTotalCount.put("", queueSize.longValue());
+    callQueueMethodTotalSize.put("", 0L);
+
+    callQueueInfo.setCallMethodCount(queueName, callQueueMethodTotalCount);
+    callQueueInfo.setCallMethodSize(queueName, callQueueMethodTotalSize);
+
+    return callQueueInfo;
+  }
{code}
Can we have FifoRpcScheduler provide the more information of holding 
CallRunner? What about wrapping the {{CallRunner}} as {{Runnable + 
getCallRunner()}}? We can call {{ThreadPoolExecutor#getQueue}} to list the 
holding {{Runnable + getCallRunner()}.

BTW, could you put ur patch on review board? see 
[reviewboard|http://hbase.apache.org/book.html#reviewboard]

> Dump summary of callQueue content; can help debugging
> -----------------------------------------------------
>
>                 Key: HBASE-16290
>                 URL: https://issues.apache.org/jira/browse/HBASE-16290
>             Project: HBase
>          Issue Type: Bug
>          Components: Operability
>    Affects Versions: 2.0.0
>            Reporter: stack
>            Assignee: Sreeram Venkatasubramanian
>              Labels: beginner
>             Fix For: 2.0.0
>
>         Attachments: DebugDump_screenshot.png, HBASE-16290.master.001.patch, 
> HBASE-16290.master.002.patch, HBASE-16290.master.003.patch, 
> HBASE-16290.master.004.patch, HBASE-16290.master.005.patch, Sample Summary.txt
>
>
> Being able to get a clue what is in a backedup callQueue could give insight 
> on what is going on on a jacked server. Just needs to summarize count, sizes, 
> call types. Useful debugging. In a servlet?



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Reply via email to