[ 
https://issues.apache.org/jira/browse/HBASE-20010?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Appy updated HBASE-20010:
-------------------------
    Description: 
* Ensure that all RPCs check that master is accepting rpcs before starting to 
process them.
 * All checks should be done in one class, either MasterRpcServices or HMaster, 
right now they are spread between the two. I think MasterRpcServices is better 
place. To that end, let's make a local fn in MasterRpcServices instead of 
references master in 50 places redundantly.

> Rename Master#checkInitialized to Master#isAcceptingRpc; Ensure called for 
> all RPC methods
> ------------------------------------------------------------------------------------------
>
>                 Key: HBASE-20010
>                 URL: https://issues.apache.org/jira/browse/HBASE-20010
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Appy
>            Priority: Major
>
> * Ensure that all RPCs check that master is accepting rpcs before starting to 
> process them.
>  * All checks should be done in one class, either MasterRpcServices or 
> HMaster, right now they are spread between the two. I think MasterRpcServices 
> is better place. To that end, let's make a local fn in MasterRpcServices 
> instead of references master in 50 places redundantly.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to