[ 
https://issues.apache.org/jira/browse/HBASE-5325?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13205215#comment-13205215
 ] 

stack commented on HBASE-5325:
------------------------------

I suppose you can't name the bean for the ServerName because you need to be 
able to locate the bean -- i.e. there'll be N instances of RegionServer beans 
and you'd then figure which belonged to which by looking at the ServerName 
attribute (I remember this is how it worked now).

Is this in branch-0.20-append branch:

+import org.apache.hadoop.metrics2.util.MBeans;

If not, this breaks our ability to run on that branch (Up to this presumed we 
could run there).  Its in 1.0.0 hadoop?  (would need to check its in CDH..)

Do classes have to have an HBase (or Hbase) prefix? Seems redundant (and we 
should be consistent).

Can we have a better name than HBaseRegionServerInfo.  It says nothing.  If it 
was RegionServerMBean or MXBean, it'd say more about what this class is about.

You can all it 'instance'.  'theInstance' is too much?

And again, publishing master, ensemble, and startcode seems like a bunch of 
info you'd never act on.  Master maybe -- you'd know which master it was 
talking too -- and perhaps ensemble because then you know who its registered 
with (though having both seems unnessary... the ensemble with its rootdir will 
tell you which cluster we belong too... perhaps you should get the cluster id 
out here?) but startcode is no good to anyone really.  Should be ServerName 
coming out here.  Thats how we uniquely identify regionservers in fs, when they 
report into the master and up in ensemble.  Might as well continue the 
identifier here.

Does this class need to take a RegionServer implementation?  Can it take a 
o.a.h.h.Server and/or a o.a.h.h.regionserver.RegionServerServices publishing 
jmx attributes?  These are Interfaces.  Might make this all easier to write 
tests on.


HbaseRegionServerMXBean should be in the regionserver/metrics package then you 
could call it MXBean or ServerMXBean.


HBaseMasterMXBean should be min master/metrics, should be HBaseMasterMXBean.  
The RegionServerInfo in it should be showing more than this small set of 
metrics if you are going to the bother of putting this stuff out on jmx (we do 
requests per region now -- should there be one of these classes per region?)  

I think that you don't need startcode if getRegionServer is returning the 
ServerName as a String.

Don't RegionState up in RegionsInTransiation have a ServerName associated too?  
YOu're not publishing this?

Again, ain't these bad names for beans up in jmx?

+    mxBean = MBeans.register("HBase", "MasterInfo",
+        mxBeanInfo);

shouldn't it be org.apache.hbase... or hbase if thats the parent for all of the 
hbase beans (Ain't there convention on bean naming -- IIRC).  MasterInfo says 
nothing.  Could it be just Master.  Then you do getServerName or what ever it 
is that returns ServerName to distingush this master from the backup Master?

Sorry for so many comments for such a small patch.  I just feel that this stuff 
can be really useful if its done right.  Else its just more stuff for us to 
maintain.  Thanks for doing this stuff lads.
                
> Expose basic information about the master-status through jmx beans 
> -------------------------------------------------------------------
>
>                 Key: HBASE-5325
>                 URL: https://issues.apache.org/jira/browse/HBASE-5325
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Hitesh Shah
>            Assignee: Hitesh Shah
>            Priority: Minor
>             Fix For: 0.94.0
>
>         Attachments: HBASE-5325.1.patch, HBASE-5325.wip.patch
>
>
> Similar to the Namenode and Jobtracker, it would be good if the hbase master 
> could expose some information through mbeans.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to