[ 
https://issues.apache.org/jira/browse/HBASE-5323?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13205610#comment-13205610
 ] 

Zhihong Yu commented on HBASE-5323:
-----------------------------------

Some comments for patch v2.
In MasterFileSystem.java, the following check should be put as first in if 
statement because it is fast:
{code}
e instanceof HLogLengthMisMatchException
{code}
In HLog.java:
{code}
+      if (e instanceof HLogLengthMisMatchException) {
+        throw new HLogLengthMisMatchException(
{code}
I don't think we need the above. Instead, we should check for e.cause in 
MasterFileSystem.java

For HLogLengthMisMatchException.java, the M in Match should be lower case.
I think it should be a generic exception. So maybe rename it to 
FileLengthMismatchException ?

For InstrumentedSequenceLogReader, please add javadoc for the class.
This class should be generic as well. How about passing the exception that 
getPos() is supposed to throw to ctor of InstrumentedSequenceLogReader ?
                
> Need to handle assertion error while splitting log through 
> ServerShutDownHandler by shutting down the master
> ------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-5323
>                 URL: https://issues.apache.org/jira/browse/HBASE-5323
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 0.90.5
>            Reporter: ramkrishna.s.vasudevan
>            Assignee: ramkrishna.s.vasudevan
>             Fix For: 0.94.0, 0.90.7
>
>         Attachments: HBASE-5323.patch, HBASE-5323.patch
>
>
> We know that while parsing the HLog we expect the proper length from HDFS.
> In WALReaderFSDataInputStream
> {code}
>               assert(realLength >= this.length);
> {code}
> We are trying to come out if the above condition is not satisfied.  But if 
> SSH.splitLog() gets this problem then it lands in the run method of 
> EventHandler.  This kills the SSH thread and so further assignment does not 
> happen.  If ROOT and META are to be assigned they cannot be.
> I think in this condition we abort the master by catching such exceptions.
> Please do suggest.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to