[ 
https://issues.apache.org/jira/browse/HBASE-20654?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16492698#comment-16492698
 ] 

Ted Yu commented on HBASE-20654:
--------------------------------

bq. Modify the updateRegionsInTransitionMetrics method of class 
AssignmentManager and add the parameter name 

The new config is to control the number of region names in each region state. 
How about naming the config:

hbase.assignment.metric.maxmum.regions.in.each.state

You can retrieve the value for this new config in:
{code}
  public AssignmentManager(final MasterServices master, final RegionStateStore 
stateStore) {
{code}
and save the value in an int field of AssignmentManager.

> Expose regions in transition thru JMX
> -------------------------------------
>
>                 Key: HBASE-20654
>                 URL: https://issues.apache.org/jira/browse/HBASE-20654
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Ted Yu
>            Assignee: liubangchen
>            Priority: Major
>
> Currently only the count of regions in transition is exposed thru JMX.
> Here is a sample snippet of the /jmx output:
> {code}
> {
>   "beans" : [ {
> ...
>   }, {
>     "name" : "Hadoop:service=HBase,name=Master,sub=AssignmentManager",
>     "modelerType" : "Master,sub=AssignmentManager",
>     "tag.Context" : "master",
> ...
>     "ritCount" : 3
> {code}
> It would be desirable to expose region name, state for the regions in 
> transition as well.
> We can place configurable upper bound on the number of entries returned in 
> case there're a lot of regions in transition.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to