[ 
https://issues.apache.org/jira/browse/HBASE-5074?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13215115#comment-13215115
 ] 

Phabricator commented on HBASE-5074:
------------------------------------

mbautin has commented on the revision "[jira] [HBASE-5074] Support checksums in 
HBase block cache".

  @dhruba: going through the diff once again. Since you've updated the 
revision, submitting existing comments against the previous version, and 
continuing with the new version.

INLINE COMMENTS
  src/main/java/org/apache/hadoop/hbase/io/hfile/ChecksumUtil.java:131 
Misspelling: "Minimun" -> Minimum
  src/main/java/org/apache/hadoop/hbase/fs/HFileSystem.java:44-45 Can these two 
be made final too?
  src/main/java/org/apache/hadoop/hbase/io/hfile/ChecksumUtil.java:145 
s/chuck/chunk/
  src/main/java/org/apache/hadoop/hbase/io/hfile/AbstractHFileReader.java:48 
Fix javadoc: do do -> do
  src/main/java/org/apache/hadoop/hbase/io/hfile/ChecksumUtil.java:38 Make this 
final, rename to DUMMY_VALUE, because this is a constant, and make the length a 
factor of 16 to take advantage of alignment.
  src/main/java/org/apache/hadoop/hbase/io/hfile/FixedFileTrailer.java:532 
s/manor/major/
  src/main/java/org/apache/hadoop/hbase/io/hfile/HFile.java:157 This comment is 
misleading. This is not something that defaults to the 16 K, but the default 
value itself. I think this should say something about how a non-default value 
is specified.
  src/main/java/org/apache/hadoop/hbase/io/hfile/HFile.java:265-271 The 
additional constructor should not be needed when 
https://issues.apache.org/jira/browse/HBASE-5442 goes in.
  src/main/java/org/apache/hadoop/hbase/io/hfile/HFile.java:409 Is it possible 
to obtain the filesystem from the input stream rather than pass it as an 
additional parameter? Or is the underlying filesystem of the input stream a 
regular one, as opposed to an HFileSystem?

REVISION DETAIL
  https://reviews.facebook.net/D1521

                
> support checksums in HBase block cache
> --------------------------------------
>
>                 Key: HBASE-5074
>                 URL: https://issues.apache.org/jira/browse/HBASE-5074
>             Project: HBase
>          Issue Type: Improvement
>          Components: regionserver
>            Reporter: dhruba borthakur
>            Assignee: dhruba borthakur
>         Attachments: D1521.1.patch, D1521.1.patch, D1521.2.patch, 
> D1521.2.patch, D1521.3.patch, D1521.3.patch, D1521.4.patch, D1521.4.patch, 
> D1521.5.patch, D1521.5.patch, D1521.6.patch, D1521.6.patch, D1521.7.patch, 
> D1521.7.patch, D1521.8.patch, D1521.8.patch, D1521.9.patch, D1521.9.patch
>
>
> The current implementation of HDFS stores the data in one block file and the 
> metadata(checksum) in another block file. This means that every read into the 
> HBase block cache actually consumes two disk iops, one to the datafile and 
> one to the checksum file. This is a major problem for scaling HBase, because 
> HBase is usually bottlenecked on the number of random disk iops that the 
> storage-hardware offers.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to