[ https://issues.apache.org/jira/browse/HBASE-20896?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16558143#comment-16558143 ]
Reid Chan edited comment on HBASE-20896 at 7/26/18 10:40 AM: ------------------------------------------------------------- Skimmed. * Please update this method java doc, still the old one. {code} public abstract void loadResultsToCache(Result[] results, boolean isHeartbeatMessage) {code} * You have {{resetCount}} method in {{ScanResultCache}}, but inheritances still hard code in method {{clear()}}: {{count = 0}}, either make use of it or remove it, for the former, make it {{protected}}. Ditto to {{resultSize}} * Create a constructor ScanResultCache(List<Result>)? a lot of duplicate code in inheritances {{this.cache = cache}} can be replaced with {{super(cache);}} * Suggest to use {{Interface}} {code} protected List<Result> cache; // Not LinkedList, unless you have to use specific methods in it{code} I'll take a deep look at the details later. was (Author: reidchan): Skimmed. * Please update this method java doc, still the old one. {code} public abstract void loadResultsToCache(Result[] results, boolean isHeartbeatMessage) {code} * You have {{resetCount}} method in {{ScanResultCache}}, but inheritances still hard code in method {{clear()}}: {{count = 0}}, etc, either make use of it or remove it, for the former, make them {{protected}}. Ditto to {{resultSize}} * Create a constructor ScanResultCache(List<Result>)? a lot of duplicate code in inheritances {{this.cache = cache}} can be replaced with {{super(cache);}} * Suggest to use {{Interface}} {code} protected List<Result> cache; // Not LinkedList, unless you have to use specific methods in it{code} I'll take a deep look at the details later. > Port HBASE-20866 to branch-1 and branch-1.4 > -------------------------------------------- > > Key: HBASE-20896 > URL: https://issues.apache.org/jira/browse/HBASE-20896 > Project: HBase > Issue Type: Sub-task > Reporter: Andrew Purtell > Assignee: Vikas Vishwakarma > Priority: Major > Fix For: 1.5.0, 1.4.7 > > Attachments: HBASE-20896.branch-1.4.001.patch, > HBASE-20896.branch-1.4.002.patch, HBASE-20896.branch-1.4.003.patch > > -- This message was sent by Atlassian JIRA (v7.6.3#76005)