[ 
https://issues.apache.org/jira/browse/HBASE-21964?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16796862#comment-16796862
 ] 

Yi Mei commented on HBASE-21964:
--------------------------------

{code:java}
def unthrottle_user_level1(args){code}
Can you please rename this method in quotas.rb?
{code:java}
READ_NUMBER = 'READ_NUMBER'.freeze
READ_SIZE = 'READ_SIZE'.freeze
WRITE_NUMBER = 'WRITE_NUMBER'.freeze
WRITE_SIZE = 'WRITE_SIZE'.freeze
REQUEST_NUMBER = 'REQUEST_NUMBER'.freeze
REQUEST_SIZE = 'REQUEST_SIZE'.freeze
{code}
There are 9 throttle type in ThrottleType, add another three in quotas.rb too? 

 

And there is a inconsistency between throttle and unthrottle when we use 
set_quota command:

for throttle, the THROTTLE_TYPE => WRITE / READ/ REQ, because we can infer the 
whole throttle type from LIMIT => '1CU/sec' / '1req' / '1K';

for unthrottle, the THROTTLE_TYPE => READ_NUMBER / READ_SIZE / WRITE_NUMBER...

is this ok? [~zghaobac]

Except the above problems, the patch looks good to me.

 

 

> unset Quota by Throttle Type
> ----------------------------
>
>                 Key: HBASE-21964
>                 URL: https://issues.apache.org/jira/browse/HBASE-21964
>             Project: HBase
>          Issue Type: Improvement
>          Components: master
>    Affects Versions: 1.4.8
>            Reporter: yaojingyi
>            Assignee: yaojingyi
>            Priority: Major
>         Attachments: HBASE-21964.branch-1.4.001.patch, 
> HBASE-21964.master.006.patch, HBASE-21964.master.007.patch, 
> image-2019-03-20-11-30-37-350.png, unthrottleByType.patch
>
>
>  
> {code:java}
> //first set_quota to  USER=> 'u1'
> set_quota TYPE => THROTTLE, USER => 'u1', THROTTLE_TYPE => WRITE, LIMIT => 
> '1000req/sec'
> //then 
> hbase(main):004:0> set_quota TYPE => THROTTLE, THROTTLE_TYPE => WRITE, USER 
> => 'u1', LIMIT => NONE
> ERROR: Unexpected arguments: {"THROTTLE_TYPE"=>"WRITE"}
> // or try "THROTTLE_TYPE"=>"WRITE_NUMBER"
> hbase(main):012:0* set_quota TYPE => THROTTLE, THROTTLE_TYPE => WRITE_NUMBER, 
> USER => 'u1', LIMIT => NONE
> NameError: uninitialized constant WRITE_NUMBER
> {code}
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to