[ 
https://issues.apache.org/jira/browse/HBASE-5564?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13237781#comment-13237781
 ] 

stack commented on HBASE-5564:
------------------------------

Patch seems reasonable.

Add curlies here:

{code}
+      if (parser.getTimestampKeyColumnIndex() != -1)
+        ts = parsed.getTimestamp();
{code}

Convention is you can do w/o curlies if all in one line (as you do later in 
this file) but if not on one line, need curlies.

Can you confirm that current behavior -- setting ts to System.currentTimeMillis 
-- is default?  It seems to be ... we set System.currentTimeMillis as time to 
use setting up the job.

A define for NO_TIMESTAMP_KEYCOLUMN_INDEX instead of using -1 directly might 
help for timestampKeyColumnIndex == -1?  Or put this test into a method whose 
name makes it obvious what the test is about ... e.g. hasTimeStampColumn()....

Patch adds nice usage commentary explaining new facility.

Looks good.
                
> Bulkload is discarding duplicate records
> ----------------------------------------
>
>                 Key: HBASE-5564
>                 URL: https://issues.apache.org/jira/browse/HBASE-5564
>             Project: HBase
>          Issue Type: Bug
>          Components: mapreduce
>    Affects Versions: 0.90.7, 0.92.2, 0.94.0, 0.96.0
>         Environment: HBase 0.92
>            Reporter: Laxman
>            Assignee: Laxman
>              Labels: bulkloader
>             Fix For: 0.96.0
>
>         Attachments: 5564.lint, HBASE-5564_trunk.1.patch, 
> HBASE-5564_trunk.1.patch, HBASE-5564_trunk.patch
>
>
> Duplicate records are getting discarded when duplicate records exists in same 
> input file and more specifically if they exists in same split.
> Duplicate records are considered if the records are from diffrent different 
> splits.
> Version under test: HBase 0.92

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to