[ https://issues.apache.org/jira/browse/HBASE-5547?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13249332#comment-13249332 ]
jirapos...@reviews.apache.org commented on HBASE-5547: ------------------------------------------------------ ----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/4633/#review6777 ----------------------------------------------------------- In the javadoc, 'backups' were used. I think backup should be good enough. src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java <https://reviews.apache.org/r/4633/#comment14940> How about naming this method createHFileArchiveManager or buildHFileArchiveManager ? src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java <https://reviews.apache.org/r/4633/#comment14941> The directory is specified by HConstants.HFILE_ARCHIVE_DIRECTORY. src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java <https://reviews.apache.org/r/4633/#comment14943> Should read 'all online region servers hosting the' src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java <https://reviews.apache.org/r/4633/#comment14944> Typo: received. src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java <https://reviews.apache.org/r/4633/#comment14942> Please add javadoc for archive. src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java <https://reviews.apache.org/r/4633/#comment14945> This would create a manager. Can we cache the archive manager ? src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java <https://reviews.apache.org/r/4633/#comment14952> Parameter for allRegionsDoneBackup() is called confirmedDone This seems to be inconsistent with the return from regionsArchivingTable() src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java <https://reviews.apache.org/r/4633/#comment14947> This call would leave the backup for tableName in an inconsistent state, right ? src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java <https://reviews.apache.org/r/4633/#comment14946> tableName should be included. src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java <https://reviews.apache.org/r/4633/#comment14948> Please mention this call is asynchronous. src/main/java/org/apache/hadoop/hbase/client/HFileArchiveManager.java <https://reviews.apache.org/r/4633/#comment14954> License. src/main/java/org/apache/hadoop/hbase/client/HFileArchiveManager.java <https://reviews.apache.org/r/4633/#comment14949> Should read 'archiving for the table' src/main/java/org/apache/hadoop/hbase/client/HFileArchiveManager.java <https://reviews.apache.org/r/4633/#comment14950> How about naming this method regionsBeingArchived or regionsBeingArchivedForTable ? I think the first should be enough since table is a parameter. src/main/java/org/apache/hadoop/hbase/regionserver/HFileArchiveMonitor.java <https://reviews.apache.org/r/4633/#comment14955> No year, please. src/main/java/org/apache/hadoop/hbase/regionserver/HFileArchiveMonitor.java <https://reviews.apache.org/r/4633/#comment14956> This doesn't sound consistent with the class being a monitor. src/main/java/org/apache/hadoop/hbase/util/HFileArchiveUtil.java <https://reviews.apache.org/r/4633/#comment14957> No year. src/main/java/org/apache/hadoop/hbase/zookeeper/HFileArchiveTracker.java <https://reviews.apache.org/r/4633/#comment14959> Year is not needed. src/main/java/org/apache/hadoop/hbase/zookeeper/RegionServerHFileTracker.java <https://reviews.apache.org/r/4633/#comment14960> License. - Ted On 2012-04-07 19:51:11, Jesse Yates wrote: bq. bq. ----------------------------------------------------------- bq. This is an automatically generated e-mail. To reply, visit: bq. https://reviews.apache.org/r/4633/ bq. ----------------------------------------------------------- bq. bq. (Updated 2012-04-07 19:51:11) bq. bq. bq. Review request for hbase, Michael Stack and Lars Hofhansl. bq. bq. bq. Summary bq. ------- bq. bq. Essentially, whenever an hfile would be deleted, it is instead moved to the archive directory. In this impl, the archive directory is on a per table basis, but defaults to '.archive'. Removing hfiles occurs in three places - compaction, merge and catalog janitor. The former and two latter are distinctly different code paths, but but did pull out some similarities. The latter two end up calling the same method, so there should be a reasonable amount of overlap. bq. bq. Implementation wise: bq. Updated the HMasterInterface to pass the calls onto the zookeeper. bq. Added a zk listener to handle updates from the master to the RS to backup. bq. Added a utility for removing files and finding archive directories bq. Added tests for the regionserver and catalogjanitor approaches. bq. Added creation of manager in regionserver. bq. bq. bq. This addresses bug HBASE-5547. bq. https://issues.apache.org/jira/browse/HBASE-5547 bq. bq. bq. Diffs bq. ----- bq. bq. src/main/java/org/apache/hadoop/hbase/HConstants.java a4b989e bq. src/main/java/org/apache/hadoop/hbase/client/HBaseAdmin.java 16e4017 bq. src/main/java/org/apache/hadoop/hbase/client/HFileArchiveManager.java PRE-CREATION bq. src/main/java/org/apache/hadoop/hbase/master/CatalogJanitor.java 79d5fdd bq. src/main/java/org/apache/hadoop/hbase/master/HMaster.java fb21bdd bq. src/main/java/org/apache/hadoop/hbase/regionserver/HFileArchiveMonitor.java PRE-CREATION bq. src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java c3df319 bq. src/main/java/org/apache/hadoop/hbase/regionserver/HRegionServer.java 8a61f7d bq. src/main/java/org/apache/hadoop/hbase/regionserver/RegionServerServices.java 6884d53 bq. src/main/java/org/apache/hadoop/hbase/regionserver/Store.java 509a467 bq. src/main/java/org/apache/hadoop/hbase/util/HFileArchiveUtil.java PRE-CREATION bq. src/main/java/org/apache/hadoop/hbase/zookeeper/HFileArchiveTracker.java PRE-CREATION bq. src/main/java/org/apache/hadoop/hbase/zookeeper/RegionServerHFileTracker.java PRE-CREATION bq. src/main/java/org/apache/hadoop/hbase/zookeeper/ZooKeeperWatcher.java 4fc105f bq. src/main/resources/hbase-default.xml 44ee689 bq. src/test/java/org/apache/hadoop/hbase/master/MockRegionServer.java 41616c8 bq. src/test/java/org/apache/hadoop/hbase/master/TestCatalogJanitor.java b4dcb83 bq. src/test/java/org/apache/hadoop/hbase/regionserver/TestRegionHFileArchiving.java PRE-CREATION bq. src/test/java/org/apache/hadoop/hbase/util/HFileArchiveTestingUtil.java PRE-CREATION bq. src/test/java/org/apache/hadoop/hbase/util/MockRegionServerServices.java 7d02759 bq. bq. Diff: https://reviews.apache.org/r/4633/diff bq. bq. bq. Testing bq. ------- bq. bq. Added two tests for the separate cases - archiving via the regionserver and for the catalog tracker. Former runs in a mini cluster and also touches the changes to HMasterInterface and zookeeper. bq. bq. bq. Thanks, bq. bq. Jesse bq. bq. > Don't delete HFiles when in "backup mode" > ----------------------------------------- > > Key: HBASE-5547 > URL: https://issues.apache.org/jira/browse/HBASE-5547 > Project: HBase > Issue Type: New Feature > Reporter: Lars Hofhansl > Assignee: Jesse Yates > > This came up in a discussion I had with Stack. > It would be nice if HBase could be notified that a backup is in progress (via > a znode for example) and in that case either: > 1. rename HFiles to be delete to <file>.bck > 2. rename the HFiles into a special directory > 3. rename them to a general trash directory (which would not need to be tied > to backup mode). > That way it should be able to get a consistent backup based on HFiles (HDFS > snapshots or hard links would be better options here, but we do not have > those). > #1 makes cleanup a bit harder. -- This message is automatically generated by JIRA. If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa For more information on JIRA, see: http://www.atlassian.com/software/jira