[ 
https://issues.apache.org/jira/browse/HBASE-5621?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13259090#comment-13259090
 ] 

Zhihong Yu commented on HBASE-5621:
-----------------------------------

For ServerManager.java:
{code}
-    HRegionInterface hri = getServerConnection(server);
+    AdminProtocol hri = getServerConnection(server);
{code}
Can we use a better variable name to hold the AdminProtocol ? Consider how it 
is used below:
{code}
+    return ProtobufUtil.openRegion(hri, region, versionOfOfflineNode);
{code}
region is already HRegionInfo. hri used to denote HRegionInfo. Now it 
represents AdminProtocol.
                
> Convert admin protocol of HRegionInterface to PB
> ------------------------------------------------
>
>                 Key: HBASE-5621
>                 URL: https://issues.apache.org/jira/browse/HBASE-5621
>             Project: HBase
>          Issue Type: Sub-task
>          Components: ipc, master, migration, regionserver
>            Reporter: Jimmy Xiang
>            Assignee: Jimmy Xiang
>             Fix For: 0.96.0
>
>         Attachments: hbase-5621_v3.patch, hbase_5621_v4.patch, 
> hbase_5621_v4.patch
>
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to