[ 
https://issues.apache.org/jira/browse/HBASE-5923?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13267568#comment-13267568
 ] 

stack commented on HBASE-5923:
------------------------------

This patch is great.  Thanks for going back and doing the cleanup.

This class should not be in filter package?
+import org.apache.hadoop.hbase.filter.WritableByteArrayComparable;

Probably hard to move it now?  Its part of a public API?  Could deprecate and 
replace w/ a more generic, non-filter specific class?  Moving it should not be 
part of this patch.  Its not so bad anyways having this filter package 
pollution since its in client facing code and clients need access to filter 
stuff...

Would think pollution:

+import 
org.apache.hadoop.hbase.protobuf.generated.ClientProtos.Condition.CompareType;

Should be pulling in a non-pb class into an Interface like this.  Can we 
encapsulate these Client conditions in a non-pb class?
                
> Cleanup checkAndXXX logic
> -------------------------
>
>                 Key: HBASE-5923
>                 URL: https://issues.apache.org/jira/browse/HBASE-5923
>             Project: HBase
>          Issue Type: Improvement
>          Components: client, regionserver
>            Reporter: Lars Hofhansl
>            Assignee: Lars Hofhansl
>            Priority: Minor
>             Fix For: 0.96.0, 0.94.1
>
>         Attachments: 5923-trunk.txt
>
>
> 1. the checkAnd{Put|Delete} method that takes a CompareOP is not exposed via 
> HTable[Interface].
> 2. there is unnecessary duplicate code in the check{Put|Delete} code in 
> HRegionServer.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to