[ 
https://issues.apache.org/jira/browse/HBASE-6785?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13471661#comment-13471661
 ] 

Ted Yu commented on HBASE-6785:
-------------------------------

{code}
+message AggregateResponseTuple {
+  repeated bytes key = 1;
+  optional bytes value = 2; 
+}
{code}
Looking at the definition from http://en.wikipedia.org/wiki/Tuple, I don't see 
the term key.
I am trying to find a better term for the above structure.
{code}
+   * Return the PB for type T
+   * @param s
+   * @return PB-message
+   */
+  ByteString getProtoForPromotedType(S s);
{code}
'type T' -> 'promoted type S'
{code}
+  public ByteString getProtoForPromotedType(Long s) {
+    log.info("getProtoForCellType " + s);
{code}
The log should be at debug level. Method name doesn't match log message.
Since the above method has same implementation as getProtoForCellType(), you 
may want to extract the body in a utility method.
                
> Convert AggregateProtocol to protobuf defined coprocessor service
> -----------------------------------------------------------------
>
>                 Key: HBASE-6785
>                 URL: https://issues.apache.org/jira/browse/HBASE-6785
>             Project: HBase
>          Issue Type: Sub-task
>          Components: Coprocessors
>            Reporter: Gary Helmling
>            Assignee: Devaraj Das
>             Fix For: 0.96.0
>
>         Attachments: Aggregate.proto, Aggregate.proto
>
>
> With coprocessor endpoints now exposed as protobuf defined services, we 
> should convert over all of our built-in endpoints to PB services.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to