[ 
https://issues.apache.org/jira/browse/HBASE-7026?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13499458#comment-13499458
 ] 

Lars Hofhansl commented on HBASE-7026:
--------------------------------------

Looks like in trunk this is already gone?!
I see stuff like this:
{code}
      if (cumulativeMetric > 0 && metric != null) {

      }
{code}

An empty if statement, that does not look like it was on purpose.
[~eclark] Is this by accident from the metric refactor?
                
> Make metrics collection in StoreScanner.java more efficient
> -----------------------------------------------------------
>
>                 Key: HBASE-7026
>                 URL: https://issues.apache.org/jira/browse/HBASE-7026
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Karthik Ranganathan
>            Assignee: Karthik Ranganathan
>
> Per the benchmarks I ran, the following block of code seems to be inefficient:
> StoreScanner.java:
> public synchronized boolean next(List<KeyValue> outResult, int limit,
>       String metric) throws IOException {
> // ...
>       // update the counter 
>       if (addedResultsSize > 0 && metric != null) {
>         HRegion.incrNumericMetric(this.metricNamePrefix + metric, 
>             addedResultsSize);
>       }
> // ...
> Removing this block increased throughput by 10%. We should move this to the 
> outer layer.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to