[ 
https://issues.apache.org/jira/browse/HBASE-6580?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Adrian Muraru updated HBASE-6580:
---------------------------------

    Affects Version/s: 0.92.2
                       0.94.2
         Release Note: New HTableInterfaceFactory implementation using shared 
ExecutorService for all HTable instances managed by HTablePool
               Status: Patch Available  (was: Open)

This is something we need in production as well. 
Digging deeper I see the underlying HConnection is already shared in the 
current HTablePool impl. (i.e there is a single, private Configuration instance 
passed when HTablePool is initialised and used for all HTable instances built 
by pool).

What is missing is a shared ExecutorService for all htable's so I called it 
SharedExecutorHTableFactory

Patch attached (it's on hbase-trunk but I can easily port to 0.92 and 0.94)
                
> New HTable pool, based on HBase(byte[], HConnection, ExecutorService) 
> constructor
> ---------------------------------------------------------------------------------
>
>                 Key: HBASE-6580
>                 URL: https://issues.apache.org/jira/browse/HBASE-6580
>             Project: HBase
>          Issue Type: Improvement
>    Affects Versions: 0.94.2, 0.92.2
>            Reporter: Lars Hofhansl
>            Priority: Minor
>
> Here I propose a very simple TablePool.
> It could be called LightHTablePool (or something - if you have a better name).
> Internally it would maintain an HConnection and an Executor service and each 
> invocation of getTable(...) would create a new HTable and close() would just 
> close it.
> In testing I find this more light weight than HTablePool and easier to 
> monitor in terms of resources used.
> It would hardly be more than a few dozen lines of code.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to